Halo Fixes
Welcome!

This site is a central place to discuss solutions for issues with Halo (for example, if the server lobby is not available).

Hopefully we can help you fix your Halo problems.

You can browse the information here without logging in, but if you register for an account then you can ask questions (or provide answers).
___________________________________________________

¡Bienvenido!

Este sitio es un lugar central para discutir soluciones para los problemas con Halo (por ejemplo, si el lobby de los servidores no está disponible).

Espero que podamos ayudarle a solucionar sus problemas de Halo.

Puede navegar por la información aquí sin iniciar sesión, pero si usted se registra para una cuenta entonces usted puede hacer preguntas (o dar respuestas).

FPS drops (possibly related to 1.0.10.2 ?)

View previous topic View next topic Go down

Re: FPS drops (possibly related to 1.0.10.2 ?)

Post by Ghost901 on Wed May 14, 2014 6:26 pm

After this recent update I seem to be getting random FPS drops while having "UseAnisotropicFilter" enabled in the Config (drops to the high 20s and low 30s, while being in the solid 58-60) but only with vsync on. It works fine with it off. Frame rate never drops below 300, however it's way above that most of the time.

Ghost901

Posts : 9
Reputation : 0
Join date : 2014-05-14

Back to top Go down

Re: FPS drops (possibly related to 1.0.10.2 ?)

Post by Roger W on Wed May 14, 2014 6:44 pm

Ghost - the only graphics-related changes were: increasing the max allowable dimensions in the resolution-selector UI, and allowing the refractive invisibility powerup on nvidia, (rather than the alpha-fade version).

How sure are you that the build change was the cause? Could it perhaps have been a while since you played (or paid attention to framerate) and in this interim, you've changed video drivers, or settings, etc.? What video card, resolution, and drivers are you using?

Roger W

Posts : 20
Reputation : 11
Join date : 2014-05-12

Back to top Go down

Re: FPS drops (possibly related to 1.0.10.2 ?)

Post by Ghost901 on Wed May 14, 2014 7:08 pm

Roger W wrote:Ghost - the only graphics-related changes were: increasing the max allowable dimensions in the resolution-selector UI, and allowing the refractive invisibility powerup on nvidia, (rather than the alpha-fade version).

How sure are you that the build change was the cause? Could it perhaps have been a while since you played (or paid attention to framerate) and in this interim, you've changed video drivers, or settings, etc.? What video card, resolution, and drivers are you using?
I was playing the full single player campaign on Custom Edition yesterday on a 1080p TV with the first test update you pushed out. I haven't messed with my drivers in weeks. I'm running it at 1680x1050 on my computer monitor. Drivers are the latest from AMD.

Here are my system specs if they are of any use.

Operating System
Windows 8.1 Pro 64-bit
CPU
AMD FX-8320 28 °C
Vishera 32nm Technology
RAM
8.00GB Dual-Channel DDR3 @ 937MHz (9-13-13-34)
Motherboard
ASUSTeK Computer INC. M5A78L-M/USB3 (AM3R2) 41 °C
Graphics
1024MB ATI AMD Radeon HD 7750 Series (ATI AIB) 36 °C
Storage
111GB KINGSTON SV300S37A120G (SSD) 29 °C
465GB SAMSUNG HD502IJ (SATA) 29 °C
Audio
VIA HD Audio(Win8.1)

Ghost901

Posts : 9
Reputation : 0
Join date : 2014-05-14

Back to top Go down

Re: FPS drops (possibly related to 1.0.10.2 ?)

Post by Skylace on Wed May 14, 2014 7:42 pm

Ghost901 wrote:Graphics
1024MB ATI AMD Radeon HD 7750 Series (ATI AIB) 36 °C
I have had a computer with new AMD graphics and they include a technology they call power-tune. It under and overclocks the GPU automatically to save power or keep it running cool.  On games like halo it may under-clock itself to much and cause low frame-rate.  In your AMD software I believe you should be able to set the clock to run at a specific frequency and have specific settings when running halo.

Skylace

Posts : 34
Reputation : 1
Join date : 2014-05-11

http://bud.boards.net it300

Back to top Go down

Re: FPS drops (possibly related to 1.0.10.2 ?)

Post by Ghost901 on Wed May 14, 2014 7:47 pm

Yes I've checked that out before and its disabled because I have it overclocked considerably. It works fine on graphic extensive games like GTA IV, Battlefield 4 and even the terrible port of Halo 2 vista, or even Source engine games (which are known to not be too hardware hungry). And as said above, it runs fine with vsync off (but tearing due to the very high framerate).

Ghost901

Posts : 9
Reputation : 0
Join date : 2014-05-14

Back to top Go down

Re: FPS drops (possibly related to 1.0.10.2 ?)

Post by Skylace on Wed May 14, 2014 8:20 pm

@Ghost901 - Then I am not sure, halo is a old game and sometimes modern graphics cards don't play well with old games.

Skylace

Posts : 34
Reputation : 1
Join date : 2014-05-11

http://bud.boards.net it300

Back to top Go down

Re: FPS drops (possibly related to 1.0.10.2 ?)

Post by Ghost901 on Wed May 14, 2014 8:23 pm

Skylace wrote:@Ghost901 - Then I am not sure, halo is a old game and sometimes modern graphics cards don't play well with old games.
Was working fine until yesterday with vsync and anisotropic filtering enabled.

Ghost901

Posts : 9
Reputation : 0
Join date : 2014-05-14

Back to top Go down

Re: FPS drops (possibly related to 1.0.10.2 ?)

Post by PÕQ~Technut on Wed May 14, 2014 8:29 pm

Roger W wrote:the only graphics-related changes were: increasing the max allowable dimensions in the resolution-selector UI, and allowing the refractive invisibility powerup on nvidia, (rather than the alpha-fade version).
With that in mind, I'd suggest we take this graphics discussion to a different forum area unless there is further evidence that this patch caused the problem (eg. try reverting to an older version and see if that helps). I can split the topic off if you wish. Thank you.


Last edited by PÕQ~Technut on Wed May 14, 2014 8:44 pm; edited 2 times in total

PÕQ~Technut

Posts : 112
Reputation : 11
Join date : 2014-05-05
Location : www.poqclan.com

http://poqclan.com poqtechnut

Back to top Go down

FPS drops (possibly related to 1.0.10.2 ?)

Post by Ghost901 on Wed May 14, 2014 8:41 pm

Yeah I will do that. it'll be hard to to determine if I'm the only one since the majority in this community will probably have Intel or Nvidia graphics and or still running Windows 7 and such. Can this still be discussed here until further replies happen? It's hard to get a stable reading in FPS when it dips since it happens so fast that it's just enough to notice the choppiness. 

EDIT: Yes split the topic if you like.

Ghost901

Posts : 9
Reputation : 0
Join date : 2014-05-14

Back to top Go down

Re: FPS drops (possibly related to 1.0.10.2 ?)

Post by Roger W on Thu May 15, 2014 12:44 am

I think it's unlikely that this patch was the cause, but if you'd like to compare
again, I put the changed binaries here:

http://ph.bungie.net/halopctestbuilds/109.zip
http://ph.bungie.net/halopctestbuilds/110.zip

NOTE: Your player profile, including your campaign unlock state, is versioned and probably already updated to 1.10; it might no longer be valid in 1.09, and might get deleted if you try. Please back up your profile (in My Documents\My Games\Halo or wherever) before down-versioning, so you don't lose you Campaign unlock progress.

Roger W

Posts : 20
Reputation : 11
Join date : 2014-05-12

Back to top Go down

Re: FPS drops (possibly related to 1.0.10.2 ?)

Post by HR_Shaft on Thu May 15, 2014 5:30 am

Not as versed as others in this, But I did notice the new build wrote a new config.txt.  When I compared the old to the new, I copied and pasted by old edits into the new, and voila - fixed.  Will defer any follow up to PM's so not to clutter the convo.

HR_Shaft

Posts : 6
Reputation : 0
Join date : 2014-05-13
Age : 51

NerveBooger2012

Back to top Go down

Re: FPS drops (possibly related to 1.0.10.2 ?)

Post by Roger W on Thu May 15, 2014 12:14 pm

Good suggestion. I didn't change config.txt - it's the same one that's been published for a few builds, but if you made edits, they will have gotten reverted.

Roger W

Posts : 20
Reputation : 11
Join date : 2014-05-12

Back to top Go down

Re: FPS drops (possibly related to 1.0.10.2 ?)

Post by Ghost901 on Thu May 15, 2014 2:52 pm

Frame rate drops only happened in Custom Edition while having the "UseAnisotropicFilter" line enabled in the config. It's not really a big problem since I can just disable V-Sync and the issues are gone. I was just concerned that it was happening just on Custom Edition after this recent update. I'll try to further debug the issue and determine if it's a problem with V-Sync which has been known to cause problems on other games.

Ghost901

Posts : 9
Reputation : 0
Join date : 2014-05-14

Back to top Go down

Re: FPS drops (possibly related to 1.0.10.2 ?)

Post by Roger W on Thu May 15, 2014 3:06 pm

Hmm, when you first said Custom Edition I thought it was a typo, but I'm confused - you said "I was playing the full single player campaign on Custom Edition". Custom Edition doesn't support Campaign mode at all.

Roger W

Posts : 20
Reputation : 11
Join date : 2014-05-12

Back to top Go down

Re: FPS drops (possibly related to 1.0.10.2 ?)

Post by Ghost901 on Thu May 15, 2014 3:16 pm

It does with a modified UI map that includes the options or by loading them with the console command "map_name" and having all the maps that have been compiled for custom editions engine.

Most of the testing for FPS drops was done in stock multiplayer maps.

Ghost901

Posts : 9
Reputation : 0
Join date : 2014-05-14

Back to top Go down

Re: FPS drops (possibly related to 1.0.10.2 ?)

Post by Roger W on Thu May 15, 2014 3:37 pm

let's only focus on MP - the other is of course unsupported. Can you reliably make the problem go away by switching back to the 1.09 binaries I posted, and come back by switching forward to 1.10?

Roger W

Posts : 20
Reputation : 11
Join date : 2014-05-12

Back to top Go down

Re: FPS drops (possibly related to 1.0.10.2 ?)

Post by Ghost901 on Thu May 15, 2014 3:52 pm

Well, the problem is only occurring in Custom Edition (stock maps). The binaries posted above are not for Custom Edition. It's not really worth debugging it since its only a small problem that can be fixed by turning V-Sync off. The tearing is only a problem on big screen TVs.

Ghost901

Posts : 9
Reputation : 0
Join date : 2014-05-14

Back to top Go down

Re: FPS drops (possibly related to 1.0.10.2 ?)

Post by Sponsored content Today at 3:24 pm


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum