Halo Fixes
Welcome!

This site is a central place to discuss solutions for issues with Halo (for example, if the server lobby is not available).

Hopefully we can help you fix your Halo problems.

You can browse the information here without logging in, but if you register for an account then you can ask questions (or provide answers).
___________________________________________________

¡Bienvenido!

Este sitio es un lugar central para discutir soluciones para los problemas con Halo (por ejemplo, si el lobby de los servidores no está disponible).

Espero que podamos ayudarle a solucionar sus problemas de Halo.

Puede navegar por la información aquí sin iniciar sesión, pero si usted se registra para una cuenta entonces usted puede hacer preguntas (o dar respuestas).

Mods will need to be updated for 1.10  (map mods are not affected)

View previous topic View next topic Go down

Mods will need to be updated for 1.10  (map mods are not affected)

Post by PÕQ~Technut on Wed May 14, 2014 2:08 am

Mods are frequently used in the Halo community. They offer features that enhance the game or that give players and server owners more options.

Most mods rely on certain structures in the Halo code to be in a particular place in memory. When Halo gets updated with a new patch, those structures move from their expected location and it breaks the mod (or the mod breaks Halo). This happens with every new patch, and 1.10 is no different. Most mods will need to be updated in order to work with 1.10. (Note: map mods are not affected.)

But it's been 4 1/2 years since the last patch (1.09). Some modders have moved on and unfortunately their mods won't get updated. 

However we still have some very active modders in the community who do plan to update their mods to work with 1.10. 

I'll try to let you know which of them are working on updates, but keep in mind that most of them can't really complete their updates until 1.10 is finalized (code could still change between now and then). 

If you know of a mod that is getting updated, feel free to post about it in this thread. And if you're a modder (other than a map modder) please register on the forums and let me know you're here (in a PM). Thank you.


Last edited by PÕQ~Technut on Wed May 14, 2014 3:42 am; edited 6 times in total

PÕQ~Technut

Posts : 112
Reputation : 11
Join date : 2014-05-05
Location : www.poqclan.com

http://poqclan.com poqtechnut

Back to top Go down

Re: Mods will need to be updated for 1.10  (map mods are not affected)

Post by PÕQ~Technut on Wed May 14, 2014 2:08 am

I'll update this post whenever I get more information.

Client mods

HAC 2  Very Happy
Btcc22 has now updated HAC 2 to work with 1.10. 
More information here.

OpenSauce   Neutral 
Kornman00 has said they hope to publish an update to work with 1.10 sometime before GameSpy shuts down.
Watch for information here.

Server mods

SAPP  Very Happy
sehé°° has updated SAPP to support 1.10 executables in addition to older executables. Servers using SAPP 8.0 are now listed ONLY on the new Master Server and will all appear as version 1.10 (no matter which executable they are actually using).
More information here.

Phasor  Wink 
Oxide has published a script that will allow 1.09 executables to be listed on the new Master Server as 1.10 servers. Or you can use the modded 1.09 executable instead. Phasor will need a more significant update at a later time to work with the 1.10 executable.
More information here.

Gandanur  Wink
Goemitar/Omega/Mathy has posted that there will be an update for Gandanur to work with 1.10. In the meantime, it should be possible to use a 1.09 server executable that is modded to use the new Master Server (Edit: and someone has done it).
More informatoin here.


Last edited by PÕQ~Technut on Tue May 27, 2014 2:56 pm; edited 11 times in total

PÕQ~Technut

Posts : 112
Reputation : 11
Join date : 2014-05-05
Location : www.poqclan.com

http://poqclan.com poqtechnut

Back to top Go down

Re: Mods will need to be updated for 1.10  (map mods are not affected)

Post by PÕQ~Technut on Wed May 14, 2014 10:01 pm

Skylace wrote:I have made a simple modification to the Version Changer made by Geomitar so that you can switch between old updates of halo and go back to 1.10 on both versions of halo (pc aka fv and ce).
http://halo-fixes.findforum.net/t21-version-changer#81

PÕQ~Technut

Posts : 112
Reputation : 11
Join date : 2014-05-05
Location : www.poqclan.com

http://poqclan.com poqtechnut

Back to top Go down

Re: Mods will need to be updated for 1.10  (map mods are not affected)

Post by PÕQ~Technut on Fri May 16, 2014 3:13 pm

PÕQ~Technut wrote:HAC 2
Btcc22 has now updated HAC 2 to work with the final release of 1.10.  Very Happy 
More information here.

PÕQ~Technut

Posts : 112
Reputation : 11
Join date : 2014-05-05
Location : www.poqclan.com

http://poqclan.com poqtechnut

Back to top Go down

Re: Mods will need to be updated for 1.10  (map mods are not affected)

Post by PÕQ~Technut on Sun May 18, 2014 2:31 am

Skylace wrote:Thanks to the work of A§H»Шιzαя∂ there is now a 1.09 haloded that can be used with Phasor and Gandanur and will report to the new lobby list on 1.10!!!
Posted here.

PÕQ~Technut

Posts : 112
Reputation : 11
Join date : 2014-05-05
Location : www.poqclan.com

http://poqclan.com poqtechnut

Back to top Go down

Re: Mods will need to be updated for 1.10  (map mods are not affected)

Post by megajd16 on Thu May 22, 2014 11:50 pm

and about optic??

megajd16

Posts : 2
Reputation : 0
Join date : 2014-05-22

Back to top Go down

Re: Mods will need to be updated for 1.10  (map mods are not affected)

Post by Amit on Sun May 25, 2014 10:31 pm

megajd16 wrote:and about optic??

Optic is compatible with 1.0.10.

Amit

Posts : 5
Reputation : 0
Join date : 2014-05-12
Location : Canada

http://RedditRescueForce.reddit.com

Back to top Go down

Re: Mods will need to be updated for 1.10  (map mods are not affected)

Post by PÕQ~Technut on Mon May 26, 2014 2:19 pm

Servers using SAPP 8.0 are now listed ONLY on the new Master Server and will all appear as version 1.10 (no matter which executable they are actually using).
http://halo-fixes.findforum.net/t63-halo-fixes-topic-sapp#389

PÕQ~Technut

Posts : 112
Reputation : 11
Join date : 2014-05-05
Location : www.poqclan.com

http://poqclan.com poqtechnut

Back to top Go down

Re: Mods will need to be updated for 1.10  (map mods are not affected)

Post by PÕQ~Technut on Tue May 27, 2014 2:50 pm

Good news! Gandanur will be updated to work with 1.10
http://www.gandanur.com/2014/05/hello-world.html
Mathy wrote:Due to the recent patch for Halo, I will update Gandanur to work with 1.10 in the next few weeks. I can't give an ETA, but there will be an update.

It was a bit of a surprise to see people still using Gandanur, but that's a good thing! Halo is still a special community, as evidenced by this patch to an 11 year old game. And the fact that community members such as Technut, kornman00, and btcc22 helped made the new Halo 1.10 patch possible is an amazing thing to see.

PÕQ~Technut

Posts : 112
Reputation : 11
Join date : 2014-05-05
Location : www.poqclan.com

http://poqclan.com poqtechnut

Back to top Go down

Re: Mods will need to be updated for 1.10  (map mods are not affected)

Post by PÕQ~Technut on Thu May 29, 2014 12:36 pm

RadWolfie wrote:Good news, H-Ext is now supported Halo 1.0.10 as of 0.5.2.2.
More information here.

PÕQ~Technut

Posts : 112
Reputation : 11
Join date : 2014-05-05
Location : www.poqclan.com

http://poqclan.com poqtechnut

Back to top Go down

Re: Mods will need to be updated for 1.10  (map mods are not affected)

Post by Sponsored content Today at 3:26 pm


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum